MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby anared » Thu Sep 25, 2014 6:10 pm

This Topic is no longer active. Check out the new operational URL at: https://podaac-tools.jpl.nasa.gov/las/

I am trying to download MODIS chlorophyll data (Chlorophyll / MODIS Aqua Level 3 Global Monthly Mapped 4 km Chlorophyll a) from http://thredds.jpl.nasa.gov/las/getUI.do

The metadata (extracted from the netcdf file) looks like:

Parameter: Chlorophyll a concentration
Measure: Mean
Units: mg m^-3000
Scaling: linear000
Scaling%20Equation: (Slope*l3m_data) + Intercept = parameter
Slope: 1.0
Intercept: 0.0

However, the data does not correspond to realistic values of chlorophyll, instead it returns discrete values (0 - 64) that I am guessing correspond with the L2 flags???.

I am not sure if I am missing something or the data is actually incorrect?
anared
 
Posts: 2
Joined: Thu Sep 25, 2014 5:45 pm

Re: MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby mgierach » Fri Sep 26, 2014 11:04 am

The data is correct. High chl-a values in current MODIS-Aqua products (as well as SeaWiFS, CZCS, etc) are associated with shallow near-shore and coastal regions. Rationale as to why is that the standard algorithms of ocean color data processing are developed for open ocean waters and thereby usually overestimate chlorophyll in shallow near-shore and coastal zones because 
of the presence of colored dissolved organic
 matter and suspended matter. Other instances that can contribute to overestimation of chlorophyll is bottom reflectance, landmass reflection, and of course atmospheric variability.
mgierach
 
Posts: 7
Joined: Thu Sep 04, 2014 9:50 am

Re: MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby anared » Sun Sep 28, 2014 4:31 pm

I understand that high chl-a values are expected in shallow waters, however the data is showing chl_a=0 for open waters and then discrete values at coastal locations, for example (See map attached):

For open waters:
DATETIME,TIME,LON,LAT,L3M_DATA
"01-JUL-2002",181,132.8,-37.15,0
"01-JUL-2002",181,132.8,-37.15,0
"01-JUL-2002",181,132.9,-37.15,0
"01-JUL-2002",181,132.9,-37.15,0
"01-JUL-2002",181,132.9,-37.15,0

Coastal area:
DATETIME,TIME,LON,LAT,L3M_DATA
"01-JUL-2002",181,137.4,-33.15,-1.E+34 (bad flag => land)
"01-JUL-2002",181,137.4,-33.15,-1.E+34 (bad flag => land)
"01-JUL-2002",181,137.5,-33.15,6
"01-JUL-2002",181,137.5,-33.15,3
"01-JUL-2002",181,137.6,-33.15,2
"01-JUL-2002",181,137.6,-33.15,1
"01-JUL-2002",181,137.6,-33.15,1

So it looks like I am getting the flags rather than the chl_a values???
Attachments
MODISA_Chl_200207_MonMean.PNG
MODISA_Chl_200207_MonMean.PNG (89.06 KiB) Viewed 11621 times
anared
 
Posts: 2
Joined: Thu Sep 25, 2014 5:45 pm

Re: MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby mgierach09 » Wed Oct 01, 2014 1:33 pm

Thank you for clarifying and pointing this issue out. I duplicated your scenario and found the same problem. We will get back with you shortly.
mgierach09
 
Posts: 3
Joined: Mon Sep 29, 2014 5:27 pm

Re: MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby podaac » Wed Oct 01, 2014 3:22 pm

We've confirmed and you are correct. There was an error in our configuration.

It turns out that our configuration in our THREDDS server for this CHLOROPHYLL dataset that our LAS server is pointing was configured with an incorrect Data Type. It was interpreting the data as INT values rather than original data type of FLOAT values. The configuration file has been updated. I've confirmed via our LAS server and did a screen grab of the image along Australia. Please note that the Color Bar Scale values was adjusted by going to the Set Plot Options ->Color fill levels (0,2,0.1).
Values added (0,2,0.1) means bands of color starting at 0, ending at 2, with an interval of 0.1.
From looking at the image in LAS it does appear to be more correct.

Thanks again. Please see attached:

chlorophyll_data.jpg
chlorophyll_data.jpg (145.3 KiB) Viewed 11603 times
podaac
Site Admin
 
Posts: 549
Joined: Mon Oct 22, 2012 4:00 pm

Re: MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby ilik » Mon Jul 11, 2016 4:21 pm

here wrote:
ton.cre wrote:I have looked at the number and analyzed them already. I understand that high chl-a values are expected in shallow waters, however the data is showing chl_a=0 for open waters and then discrete values at coastal locations, for example (See map attached):

For open waters:
DATETIME,TIME,LON,LAT,L3M_DATA
"01-JUL-2002",181,132.8,-37.15,0
"01-JUL-2002",181,132.8,-37.15,0
"01-JUL-2002",181,132.9,-37.15,0
"01-JUL-2002",181,132.9,-37.15,0
"01-JUL-2002",181,132.9,-37.15,0

Coastal area:
DATETIME,TIME,LON,LAT,L3M_DATA
"01-JUL-2002",181,137.4,-33.15,-1.E+34 (bad flag => land)
"01-JUL-2002",181,137.4,-33.15,-1.E+34 (bad flag => land)
"01-JUL-2002",181,137.5,-33.15,6
"01-JUL-2002",181,137.5,-33.15,3
"01-JUL-2002",181,137.6,-33.15,2
"01-JUL-2002",181,137.6,-33.15,1
"01-JUL-2002",181,137.6,-33.15,1

So it looks like I am getting the flags rather than the chl_a values???


We've confirmed and you are correct. There was an error in our configuration.

It turns out that our configuration in our THREDDS server for this CHLOROPHYLL dataset that our LAS server is pointing was configured with an incorrect Data Type. It was interpreting the data as INT values rather than original data type of FLOAT values. The configuration file has been updated. I've confirmed via our LAS server and did a screen grab of the image along Australia. Please note that the Color Bar Scale values was adjusted by going to the Set Plot Options ->Color fill levels (0,2,0.1).
Values added (0,2,0.1) means bands of color starting at 0, ending at 2, with an interval of 0.1.
From looking at the image in LAS it does appear to be more correct.

Thanks again. Please see attached:

chlorophyll_data.jpg


Hello, I am having the same problem, I am not sure what you mean by LAS server was incorrectly configured. How do I change it to the correct configuration? sorry for my bad English.
Last edited by ilik on Thu Nov 17, 2016 3:55 pm, edited 1 time in total.
ilik
 
Posts: 1
Joined: Mon Jul 11, 2016 4:07 pm

Re: MODIS chlorophyll from thredds.jpl.nasa.gov/las/getUI.do

Postby podaac » Mon Jul 18, 2016 10:52 am

Thank you for your inquiry.

To better assist you, can you please provide additional details on what problems you are experiencing? We have verified our THREDDS configuration and confirmed that we have the correct settings for this CHLOROPHYLL dataset.

Please note that you have referenced an old post, and that version of LAS is no longer available.

Please visit the following forums:
Video Tutorial on LAS Usage for Visualization & Subsetting

LAS v 8.4 UAT Testing Feedback

Also, to view LAS documentation and tutorial, please see: ftp://podaac.jpl.nasa.gov/misc/web/tutorials/las/
podaac
Site Admin
 
Posts: 549
Joined: Mon Oct 22, 2012 4:00 pm


Return to Data Access